What’s Vulnerable › Vulnerabilities
CVE-2025-43863: vantage6 lacks brute-force protection on change password functionality
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-307
Description
vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct. This vulnerability is fixed in 4.11.
Affected products
- vantage6: before 4.11.0 — fixed in 4.11.0
How to fix
Upgrade to a fixed version: vantage6 4.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43863 or the next vulnerability affects your stack