What’s Vulnerable › Vulnerabilities
CVE-2025-43903
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-18 · updated 2026-06-17
- Weakness: CWE-347
Description
NSSCryptoSignBackend.cc in Poppler before 25.04.0 does not verify the adbe.pkcs7.sha1 signatures on documents, resulting in potential signature forgeries.
Affected products
- poppler: before 25.04.0 — fixed in 25.04.0
How to fix
Upgrade to a fixed version: poppler 25.04.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43903 or the next vulnerability affects your stack