What’s Vulnerable › Vulnerabilities

CVE-2025-43915

Description

In Linkerd edge releases before edge-25.2.1, and Buoyant Enterprise for Linkerd releases 2.13.0–2.13.7, 2.14.0–2.14.10, 2.15.0–2.15.7, 2.16.0–2.16.4, and 2.17.0–2.17.1, resource exhaustion can occur for Linkerd proxy metrics.

Affected products

How to fix

Upgrade to a fixed version: linkerd Buoyant 2.16.5, 2.17.2; Linkerd 25.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-43915 or the next vulnerability affects your stack