What’s Vulnerable › Vulnerabilities
CVE-2025-43954
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-20 · updated 2026-06-17
- Weakness: CWE-79
Description
QMarkdown (aka quasar-ui-qmarkdown) before 2.0.5 allows XSS via headers even when when no-html is set.
Affected products
- Quasar QMarkdown: before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: Quasar QMarkdown 2.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/quasarframework/quasar-ui-qmarkdown/commit/b61dff84851c45369cf931db5bd93db177c657f6
- https://github.com/quasarframework/quasar-ui-qmarkdown/compare/v2.0.4...v2.0.5
Get alerted when CVE-2025-43954 or the next vulnerability affects your stack