What’s Vulnerable › Vulnerabilities
CVE-2025-43962
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-21 · updated 2026-06-17
- Weakness: CWE-125
Description
In LibRaw before 0.21.4, phase_one_correct in decoders/load_mfbacks.cpp has out-of-bounds reads for tag 0x412 processing, related to large w0 or w1 values or the frac and mult calculations.
Affected products
- LibRaw: before 0.21.4 — fixed in 0.21.4
How to fix
Upgrade to a fixed version: LibRaw 0.21.4. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/commit/66fe663e02a4dd610b4e832f5d9af326709336c2
- https://github.com/LibRaw/LibRaw/compare/0.21.3...0.21.4
- https://www.libraw.org/news/libraw-0-21-4-release
- https://lists.debian.org/debian-lts-announce/2025/04/msg00038.html
Get alerted when CVE-2025-43962 or the next vulnerability affects your stack