What’s Vulnerable › Vulnerabilities
CVE-2025-43964
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-21 · updated 2026-06-17
- Weakness: CWE-1284
Description
In LibRaw before 0.21.4, tag 0x412 processing in phase_one_correct in decoders/load_mfbacks.cpp does not enforce minimum w0 and w1 values.
Affected products
- LibRaw: before 0.21.4 — fixed in 0.21.4
How to fix
Upgrade to a fixed version: LibRaw 0.21.4. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/commit/a50dc3f1127d2e37a9b39f57ad9bb2ebb60f18c0
- https://github.com/LibRaw/LibRaw/compare/0.21.3...0.21.4
- https://www.libraw.org/news/libraw-0-21-4-release
- https://lists.debian.org/debian-lts-announce/2025/04/msg00038.html
Get alerted when CVE-2025-43964 or the next vulnerability affects your stack