What’s Vulnerable › Vulnerabilities
CVE-2025-43965
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-23 · updated 2026-06-17
- Weakness: CWE-131
Description
In MIFF image processing in ImageMagick before 7.1.1-44, image depth is mishandled after SetQuantumFormat is used.
Affected products
- Debian Linux: 11.0
- ImageMagick: before 7.1.1-44 — fixed in 7.1.1-44
How to fix
Upgrade to a fixed version: ImageMagick 7.1.1-44. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/bac413a26073923d3ffb258adaab07fb3fe8fdc9
- https://github.com/ImageMagick/Website/blob/main/ChangeLog.md#711-44---2025-02-22
- https://lists.debian.org/debian-lts-announce/2025/04/msg00035.html
Get alerted when CVE-2025-43965 or the next vulnerability affects your stack