What’s Vulnerable › Vulnerabilities
CVE-2025-43972
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-21 · updated 2026-06-17
- Weakness: CWE-1284
Description
An issue was discovered in GoBGP before 3.35.0. An attacker can cause a crash in the pkg/packet/bgp/bgp.go flowspec parser by sending fewer than 20 bytes in a certain context.
Affected products
- osrg GoBGP: before 3.35.0 — fixed in 3.35.0
How to fix
Upgrade to a fixed version: osrg GoBGP 3.35.0. Check the vendor advisory for mitigations.
References
- https://github.com/osrg/gobgp/commit/ca7383f450f7b296c5389feceef2467de5ab6e5a
- https://github.com/osrg/gobgp/compare/v3.34.0...v3.35.0
Get alerted when CVE-2025-43972 or the next vulnerability affects your stack