What’s Vulnerable › Vulnerabilities
CVE-2025-43973
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-21 · updated 2026-06-17
- Weakness: CWE-193
Description
An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.
Affected products
- osrg GoBGP: before 3.35.0 — fixed in 3.35.0
How to fix
Upgrade to a fixed version: osrg GoBGP 3.35.0. Check the vendor advisory for mitigations.
References
- https://github.com/osrg/gobgp/commit/5693c58a4815cc6327b8d3b6980f0e5aced28abe
- https://github.com/osrg/gobgp/compare/v3.34.0...v3.35.0
Get alerted when CVE-2025-43973 or the next vulnerability affects your stack