What’s Vulnerable › Vulnerabilities
CVE-2025-44108
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-19 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored Cross-Site Scripting (XSS) vulnerability exists in the administration panel of Flatpress CMS before 1.4 via the gallery captions component. An attacker with admin privileges can inject a malicious JavaScript payload into the system, which is then stored persistently.
Affected products
- flatpressblog/flatpress: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.4. Check the vendor advisory for mitigations.
References
- https://github.com/flatpressblog/flatpress/commit/24a6feacf1747ec19725b52c097715c8ab9c4559
- https://github.com/flatpressblog/flatpress/releases/tag/1.3.1
- https://github.com/flatpressblog/flatpress/releases/tag/1.4.rc2
- https://harish0x.github.io/blog/CVE-2025-44108
- https://harish0x.github.io/blog/CVE-2025-44108
Get alerted when CVE-2025-44108 or the next vulnerability affects your stack