What’s Vulnerable › Vulnerabilities
CVE-2025-4419: Hot Random Image <= 1.9.2 - Path Traversal to Authenticated (Contributor+) Limited Arbitrary Image Access via path Parameter
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-22 · updated 2026-06-17
- Weakness: CWE-22
Description
The Hot Random Image plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.9.2 via the 'path' parameter. This makes it possible for authenticated attackers, with Contributor-level access and above, to access arbitrary images with allowed extensions, outside of the originally intended directory.
Affected products
- hotwptemplates Hot Random Image: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: hotwptemplates Hot Random Image 1.9.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/hot-random-image/tags/1.9.2/hot_random_image.php#L57
- https://plugins.trac.wordpress.org/changeset/3298033/
- https://wordpress.org/plugins/hot-random-image/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d6628232-0bd1-4194-8322-36084b1eb0f7?source=cve
Get alerted when CVE-2025-4419 or the next vulnerability affects your stack