What’s Vulnerable › Vulnerabilities

CVE-2025-4439: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that could have allowed an authenticated user to perform cross-site scripting attacks when the instance is served through certain content delivery networks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.0.5, 18.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-4439 or the next vulnerability affects your stack