What’s Vulnerable › Vulnerabilities
CVE-2025-4520: Uncanny Automator <= 6.4.0.2 - Missing Authorization to Authenticated (Subscriber+) Plugin Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-862
Description
The Uncanny Automator plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on multiple AJAX functions in versions up to, and including, 6.4.0.2. This makes it possible for authenticated attackers, with subscriber-level permissions or above to update plugin settings.
Affected products
- uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin: before 6.5.0 — fixed in 6.5.0
How to fix
Upgrade to a fixed version: uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin 6.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/uncanny-automator/tags/6.4.0.2/src/integrations/keap/helpers/keap-helpers.php#L99
- https://www.wordfence.com/threat-intel/vulnerabilities/id/db5b5fa1-67b5-4103-93b0-682200199a71?source=cve
Get alerted when CVE-2025-4520 or the next vulnerability affects your stack