What’s Vulnerable › Vulnerabilities

CVE-2025-4573: LDAP Injection in Mattermost Enterprise Edition When Using Active Directory

Description

Mattermost versions 10.7.x <= 10.7.1, 10.6.x <= 10.6.3, 10.5.x <= 10.5.4, 9.11.x <= 9.11.13 fail to properly validate LDAP group ID attributes, allowing an authenticated administrator with PermissionSysconsoleWriteUserManagementGroups permission to execute LDAP search filter injection via the PUT /api/v4/ldap/groups/{remote_id}/link API when objectGUID is configured as the Group ID Attribute.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.5, 10.6.4, 10.7.2, 9.11.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-4573 or the next vulnerability affects your stack