What’s Vulnerable › Vulnerabilities
CVE-2025-45769: php-jwt contains weak encryption
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-31 · updated 2026-06-17
- Weakness: CWE-326
Description
php-jwt v6.11.0 was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.
Affected products
- Google Firebase Php-Jwt: through 6.11.0
- Packagist Firebase/Php-Jwt: before 7.0.0; 1.0.0, 2.0.0, v2.1.0, v2.2.0, v3.0.0, v4.0.0 (+28) — fixed in 7.0.0
How to fix
Upgrade to a fixed version: Packagist Firebase/Php-Jwt 7.0.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/ZupeiNie/83756316c4c24fe97a50176a92608db3
- https://github.com/advisories/GHSA-2x45-7fc3-mxwq
- https://github.com/firebase
- https://github.com/firebase/php-jwt
- https://github.com/firebase/php-jwt/issues/620
- https://github.com/firebase/php-jwt/pull/613
- https://github.com/firebase/php-jwt/releases/tag/v7.0.0
- https://github.com/github/advisory-database/pull/6954
Get alerted when CVE-2025-45769 or the next vulnerability affects your stack