What’s Vulnerable › Vulnerabilities
CVE-2025-4594: Tournamatch <= 4.6.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Tournamatch plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'trn-ladder-registration-button' shortcode in all versions up to, and including, 4.6.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Tournamatch: before 4.6.2 — fixed in 4.6.2
How to fix
Upgrade to a fixed version: Tournamatch 4.6.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tournamatch/tags/4.6.1/includes/shortcodes/class-shortcodes.php#L273
- https://plugins.trac.wordpress.org/changeset/3295681/tournamatch/trunk/includes/shortcodes/class-shortcodes.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fc912831-bbdd-4f8f-a620-47e41b1b731d?source=cve
Get alerted when CVE-2025-4594 or the next vulnerability affects your stack