What’s Vulnerable › Vulnerabilities
CVE-2025-46011
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-89
Description
Listmonk v4.1.0 (fixed in v5.0.0) is vulnerable to SQL Injection in the QuerySubscribers function which allows attackers to escalate privileges.
Affected products
- knadh listmonk: from 2.4.0 before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: knadh listmonk 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/kevinroleke/security/tree/main/CVE-2025-46011
- https://github.com/knadh/listmonk/commit/4b805f885b9f5a20126ec06f8b59dc448c4af33b
- https://github.com/knadh/listmonk/issues/2412
- https://github.com/knadh/listmonk/releases/tag/v4.1.0
- https://github.com/knadh/listmonk/releases/tag/v5.0.0
Get alerted when CVE-2025-46011 or the next vulnerability affects your stack