What’s Vulnerable › Vulnerabilities
CVE-2025-46149
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-25 · updated 2026-06-17
- Weakness: CWE-617
Description
In PyTorch before 2.7.0, when inductor is used, nn.Fold has an assertion error.
Affected products
- PyTorch: from 2.6.0 before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: PyTorch 2.7.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/shaoyuyoung/4bcefba4004f8271e64b5185c95a248a
- https://github.com/pytorch/pytorch/issues/147848
- https://github.com/pytorch/pytorch/pull/147961
Get alerted when CVE-2025-46149 or the next vulnerability affects your stack