What’s Vulnerable › Vulnerabilities
CVE-2025-46228: WordPress Event post plugin <= 5.9.11 - Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bastien Ho Event post event-post allows DOM-Based XSS.This issue affects Event post: from n/a through <= 5.9.11.
Affected products
- Bastien Ho Event post: before 5.10.0 — fixed in 5.10.0
How to fix
Upgrade to a fixed version: Bastien Ho Event post 5.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46228 or the next vulnerability affects your stack