What’s Vulnerable › Vulnerabilities
CVE-2025-46233: WordPress Sirv plugin <= 7.5.3 - Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Sirv CDN and Image Hosting Sirv sirv allows Stored XSS.This issue affects Sirv: from n/a through <= 7.5.3.
Affected products
- sirv Image Optimizer, Resizer and CDN – Sirv: before 7.5.4 — fixed in 7.5.4
How to fix
Upgrade to a fixed version: sirv Image Optimizer, Resizer and CDN – Sirv 7.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46233 or the next vulnerability affects your stack