What’s Vulnerable › Vulnerabilities
CVE-2025-46235: WordPress SKT Blocks – Gutenberg based Page Builder plugin <= 2.0 - Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in sonalsinha21 SKT Blocks skt-blocks allows Stored XSS.This issue affects SKT Blocks: from n/a through <= 2.0.
Affected products
- sonalsinha21 SKT Blocks: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: sonalsinha21 SKT Blocks 2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46235 or the next vulnerability affects your stack