What’s Vulnerable › Vulnerabilities
CVE-2025-46239: WordPress Theme Switcha plugin <= 3.4 - Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jeff Starr Theme Switcha theme-switcha allows Stored XSS.This issue affects Theme Switcha: from n/a through <= 3.4.
Affected products
- specialk Theme Switcha – Easily Switch Themes for Development and Testing: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: specialk Theme Switcha – Easily Switch Themes for Development and Testing 3.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46239 or the next vulnerability affects your stack