What’s Vulnerable › Vulnerabilities
CVE-2025-46254: WordPress Visual Composer Website Builder plugin <= 45.10.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Visual Composer Visual Composer Website Builder visualcomposer allows Stored XSS.This issue affects Visual Composer Website Builder: from n/a through <= 45.10.0.
Affected products
- Visual Composer Website Builder: before 45.11.0 — fixed in 45.11.0
How to fix
Upgrade to a fixed version: Visual Composer Website Builder 45.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46254 or the next vulnerability affects your stack