What’s Vulnerable › Vulnerabilities
CVE-2025-46295
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-16 · updated 2026-06-17
- Weakness: CWE-94
Description
Apache Commons Text versions prior to 1.10.0 included interpolation features that could be abused when applications passed untrusted input into the text-substitution API. Because some interpolators could trigger actions like executing commands or accessing external resources, an attacker could potentially achieve remote code execution. This vulnerability has been fully addressed in FileMaker Server 22.0.4.
Affected products
- Claris FileMaker Server: before 22.0.4 — fixed in 22.0.4
How to fix
Upgrade to a fixed version: Claris FileMaker Server 22.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46295 or the next vulnerability affects your stack