What’s Vulnerable › Vulnerabilities
CVE-2025-46331: OpenFGA Authorization Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-30 · updated 2026-06-17
- Weakness: CWE-284
Description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.10 to v1.3.6 (Helm chart <= openfga-0.2.28, docker <= v.1.8.10) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. This issue has been patched in version 1.8.11.
Affected products
- openfga Helm Charts: from 0.1.36 before 0.2.29 — fixed in 0.2.29
- openfga: from 1.3.6 before 1.8.11 — fixed in 1.8.11
How to fix
Upgrade to a fixed version: openfga Helm Charts 0.2.29; openfga 1.8.11. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/commit/244302e7a8b979d66cc1874a3899cdff7d47862f
- https://github.com/openfga/openfga/security/advisories/GHSA-w222-m46c-mgh6
Get alerted when CVE-2025-46331 or the next vulnerability affects your stack