What’s Vulnerable › Vulnerabilities
CVE-2025-46334: Git GUI malicious command injection on Windows
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-78
Description
Git GUI allows you to use the Git source control management tools via a GUI. A malicious repository can ship versions of sh.exe or typical textconv filter programs such as astextplain. Due to the unfortunate design of Tcl on Windows, the search path when looking for an executable always includes the current directory. The mentioned programs are invoked when the user selects Git Bash or Browse Files from the menu. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.
Affected products
- j6t git-gui: before 2.43.7; from 2.44.0, < 2.44.4; from 2.45.0, < 2.45.4; from 2.46.0, < 2.46.4; from 2.47.0, < 2.47.3; from 2.48.0, < 2.48.2
References
- https://github.com/j6t/git-gui/compare/dcda716dbc9c90bcac4611bd1076747671ee0906..a1ccd2512072cf52835050f4c97a4fba9f0ec8f9
- https://github.com/j6t/git-gui/security/advisories/GHSA-7px4-9hg2-fvhx
- http://www.openwall.com/lists/oss-security/2025/07/08/4
Get alerted when CVE-2025-46334 or the next vulnerability affects your stack