What’s Vulnerable › Vulnerabilities
CVE-2025-46338: Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.
Affected products
- advplyr audiobookshelf: before 2.21.0 — fixed in 2.21.0
How to fix
Upgrade to a fixed version: advplyr audiobookshelf 2.21.0. Check the vendor advisory for mitigations.
References
- https://github.com/advplyr/audiobookshelf/commit/35870a01583b2947030f4e3d4ac769c3ff298386
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-47g3-c5hx-2q3w
Get alerted when CVE-2025-46338 or the next vulnerability affects your stack