What’s Vulnerable › Vulnerabilities
CVE-2025-46344: Auth0 NextJS SDK v4 Missing Session Invalidation
- Severity: medium (CVSS 4.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-29 · updated 2026-06-17
- Weakness: CWE-613
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.
Affected products
- auth0 nextjs-auth0: from 4.0.1, < 4.5.1
References
- https://github.com/auth0/nextjs-auth0/commit/a4f061aed02ffa132feca8adfbd11704df17e1c3
- https://github.com/auth0/nextjs-auth0/releases/tag/v4.5.1
- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-pjr6-jx7r-j4r6
Get alerted when CVE-2025-46344 or the next vulnerability affects your stack