What’s Vulnerable › Vulnerabilities
CVE-2025-46345: Auth0 Account Link Extension JWT Invalid Signature Validation
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-290
Description
Auth0 Account Link Extension is an extension aimed to help link accounts easily. Versions 2.3.4 to 2.6.6 do not verify the signature of the provided JWT. This allows the user the ability to supply a forged token and the potential to access user information without proper authorization. This issue has been patched in versions 2.6.7, 2.7.0, and 3.0.0. It is recommended to upgrade to version 3.0.0 or greater.
Affected products
- auth0-extensions auth0-account-link-extension: from 2.3.4, < 2.6.7
References
- https://github.com/auth0-extensions/auth0-account-link-extension/pull/187
- https://github.com/auth0-extensions/auth0-account-link-extension/security/advisories/GHSA-j2jh-rqff-7vmg
Get alerted when CVE-2025-46345 or the next vulnerability affects your stack