What’s Vulnerable › Vulnerabilities
CVE-2025-46347: YesWiki Remote Code Execution via Arbitrary PHP File Write and Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-29 · updated 2026-06-17
- Weakness: CWE-116
Description
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki vulnerable to remote code execution. An arbitrary file write can be used to write a file with a PHP extension, which then can be browsed to in order to execute arbitrary code on the server, resulting in a full compromise of the server. This could potentially be performed unwittingly by a user. This issue has been patched in version 4.5.4.
Affected products
- yeswiki: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: yeswiki 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/commit/8fe5275a78dc7e0f9c242baa3cbac6b5ac1cc066
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-88xg-v53p-fpvf
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-88xg-v53p-fpvf
Get alerted when CVE-2025-46347 or the next vulnerability affects your stack