What’s Vulnerable › Vulnerabilities
CVE-2025-46349: YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-29 · updated 2026-06-17
- Weakness: CWE-79
Description
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.
Affected products
- yeswiki: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: yeswiki 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/pull/1264/commits/6edde40eb7eeb5d60619ac4d1e0a0422d92e9524
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-2f8p-qqx2-gwr2
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-2f8p-qqx2-gwr2
Get alerted when CVE-2025-46349 or the next vulnerability affects your stack