What’s Vulnerable › Vulnerabilities
CVE-2025-46350: Yeswiki Vulnerable to Authenticated Reflected Cross-site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-29 · updated 2026-06-17
- Weakness: CWE-79
Description
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, an attacker can use a reflected cross-site scripting attack to steal cookies from an authenticated user by having them click on a malicious link. Stolen cookies allow the attacker to take over the user’s session. This vulnerability may also allow attackers to deface the website or embed malicious content. This issue has been patched in version 4.5.4.
Affected products
- yeswiki: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: yeswiki 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/commit/e2603176a4607b83659635a0c517550d4a171cb9
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-cg4f-cq8h-3ch8
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-cg4f-cq8h-3ch8
Get alerted when CVE-2025-46350 or the next vulnerability affects your stack