What’s Vulnerable › Vulnerabilities
CVE-2025-4638: Improper Pointer Arithmetic in pcl
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic. Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.
Affected products
- Pointclouds Point Cloud Library: before 1.14.0 — fixed in 1.14.0
How to fix
Upgrade to a fixed version: Pointclouds Point Cloud Library 1.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/PointCloudLibrary/pcl/blob/master/surface/CMakeLists.txt#L70
- https://github.com/PointCloudLibrary/pcl/commit/502bd2b013ce635f21632d523aa8cf2e04f7b7ac
- https://github.com/PointCloudLibrary/pcl/pull/6245
Get alerted when CVE-2025-4638 or the next vulnerability affects your stack