What’s Vulnerable › Vulnerabilities
CVE-2025-46392: Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-09 · updated 2026-06-17
- Weakness: CWE-400
Description
Uncontrolled Resource Consumption vulnerability in Apache Commons Configuration 1.x. There are a number of issues in Apache Commons Configuration 1.x that allow excessive resource consumption when loading untrusted configurations or using unexpected usage patterns. The Apache Commons Configuration team does not intend to fix these issues in 1.x. Apache Commons Configuration 1.x is still safe to use in scenario's where you only load trusted configurations. Users that load untrusted configurations or give attackers control over usage patterns are recommended to upgrade to the 2.x version line, which fixes these issues. Apache Commons Configuration 2.x is not a drop-in replacement, but as it uses a separate Maven groupId and Java package namespace they can be loaded side-by-side, making it possible to do a gradual migration.
Affected products
- Apache Software Foundation Apache Commons Configuration: from 1.0 before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Configuration 2.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/y1pl0mn3opz6kwkm873zshjdxq3dwq5s
- https://www.cve.org/CVERecord?id=CVE-2024-29131
- https://www.cve.org/CVERecord?id=CVE-2024-29133
Get alerted when CVE-2025-46392 or the next vulnerability affects your stack