What’s Vulnerable › Vulnerabilities
CVE-2025-46417
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-24 · updated 2026-06-17
- Weakness: CWE-184
Description
The unsafe globals in Picklescan before 0.0.25 do not include ssl. Consequently, ssl.get_server_certificate can exfiltrate data via DNS after deserialization.
Affected products
- picklescan: before 0.0.25 — fixed in 0.0.25
How to fix
Upgrade to a fixed version: picklescan 0.0.25. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-93mv-x874-956g
- https://github.com/mmaitre314/picklescan/pull/40
- https://github.com/advisories/GHSA-93mv-x874-956g
Get alerted when CVE-2025-46417 or the next vulnerability affects your stack