What’s Vulnerable › Vulnerabilities
CVE-2025-46430
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-10 · updated 2026-10-07
- Weakness: CWE-250
Description
Dell Display and Peripheral Manager, versions prior to 2.1.2.12, contains an Execution with Unnecessary Privileges vulnerability in the Installer. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of Privileges.
Affected products
- Dell Display and Peripheral Manager: before 2.1.2.12 — fixed in 2.1.2.12
How to fix
Upgrade to a fixed version: Dell Display and Peripheral Manager 2.1.2.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46430 or the next vulnerability affects your stack