What’s Vulnerable › Vulnerabilities

CVE-2025-4648: A user with elevated privileges can inject XSS by altering the content of a SVG media during the submit request.

Description

The content of a SVG file, received as input in Centreon web, was not properly checked. Allows Reflected XSS. A user with elevated privileges can inject JS script by altering the content of a SVG media, during the submit request. This issue affects web: from 24.10.0 before 24.10.5, from 24.04.0 before 24.04.11, from 23.10.0 before 23.10.22, from 23.04.0 before 23.04.27, from 22.10.0 before 22.10.29.

Affected products

How to fix

Upgrade to a fixed version: Centreon 22.10.29, 23.04.27, 23.10.22, 24.04.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-4648 or the next vulnerability affects your stack