What’s Vulnerable › Vulnerabilities
CVE-2025-4652: Broadstreet < 1.51.8 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Broadstreet WordPress plugin before 1.51.8 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- broadstreetads Broadstreet: before 1.51.8 — fixed in 1.51.8
How to fix
Upgrade to a fixed version: broadstreetads Broadstreet 1.51.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2a18ab96-ba95-4599-824f-df12e4851e6d/
- https://wpscan.com/vulnerability/2a18ab96-ba95-4599-824f-df12e4851e6d/
Get alerted when CVE-2025-4652 or the next vulnerability affects your stack