What’s Vulnerable › Vulnerabilities
CVE-2025-46548: Apache Pekko Management, Apache Pekko Management, Apache Pekko Management, Akka Management, Akka Management, Akka Management: management API basic authentication is not effective
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-03 · updated 2026-06-17
- Weakness: CWE-287
Description
If you enable Basic Authentication in Pekko Management using the Java DSL, the authenticator may not be properly applied. Users that rely on authentication instead of making sure the Management API ports are only available to trusted users are recommended to upgrade to version 1.1.1, which fixes this issue. Akka was affected by the same issue and has released the fix in version 1.6.1.
Affected products
- Akka Management: before 1.6.1 — fixed in 1.6.1
- Apache Pekko Management: from 1.0.0 through 1.1.1
How to fix
Upgrade to a fixed version: Akka Management 1.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/akka/akka-management/pull/1385
- https://github.com/apache/pekko-management/pull/418
- https://lists.apache.org/thread/tnd84hj9w0ggjcft6cp12q67d5jzhp66
- http://www.openwall.com/lists/oss-security/2025/06/03/7
Get alerted when CVE-2025-46548 or the next vulnerability affects your stack