What’s Vulnerable › Vulnerabilities
CVE-2025-46560: vLLM phi4mm: Quadratic Time Complexity in Input Token Processing leads to denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-30 · updated 2026-06-17
- Weakness: CWE-1333
Description
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.8.0 and prior to 0.8.5 are affected by a critical performance vulnerability in the input preprocessing logic of the multimodal tokenizer. The code dynamically replaces placeholder tokens (e.g., <|audio_|>, <|image_|>) with repeated tokens based on precomputed lengths. Due to inefficient list concatenation operations, the algorithm exhibits quadratic time complexity (O(n²)), allowing malicious actors to trigger resource exhaustion via specially crafted inputs. This issue has been patched in version 0.8.5.
Affected products
- vllm-project vllm: from 0.8.0 before 0.8.5 — fixed in 0.8.5
How to fix
Upgrade to a fixed version: vllm-project vllm 0.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/blob/8cac35ba435906fb7eb07e44fe1a8c26e8744f4e/vllm/model_executor/models/phi4mm.py#L1182-L1197
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vc6m-hm49-g9qg
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vc6m-hm49-g9qg
Get alerted when CVE-2025-46560 or the next vulnerability affects your stack