What’s Vulnerable › Vulnerabilities
CVE-2025-46565: Vite's server.fs.deny bypassed with /. for files under project root
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-22
Description
Vite is a frontend tooling framework for javascript. Prior to versions 6.3.4, 6.2.7, 6.1.6, 5.4.19, and 4.5.14, the contents of files in the project root that are denied by a file matching pattern can be returned to the browser. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. Only files that are under project root and are denied by a file matching pattern can be bypassed. `server.fs.deny` can contain patterns matching against files (by default it includes .env, .env.*, *.{crt,pem} as such patterns). These patterns were able to bypass for files under `root` by using a combination of slash and dot (/.). This issue has been patched in versions 6.3.4, 6.2.7, 6.1.6, 5.4.19, and 4.5.14.
Affected products
- vitejs vite: before 4.5.14; from 5.0.0 before 5.4.19; from 6.0.0 before 6.1.6; from 6.2.0 before 6.2.7; from 6.3.0 before 6.3.4 — fixed in 4.5.14, 5.4.19, 6.1.6, 6.2.7, 6.3.4
How to fix
Upgrade to a fixed version: vitejs vite 4.5.14, 5.4.19, 6.1.6, 6.2.7. Check the vendor advisory for mitigations.
References
- https://github.com/vitejs/vite/commit/c22c43de612eebb6c182dd67850c24e4fab8cacb
- https://github.com/vitejs/vite/security/advisories/GHSA-859w-5945-r5v3
- https://github.com/vitejs/vite/security/advisories/GHSA-859w-5945-r5v3
Get alerted when CVE-2025-46565 or the next vulnerability affects your stack