What’s Vulnerable › Vulnerabilities

CVE-2025-4657

Description

A buffer overflow vulnerability was reported in the Lenovo Protection Driver, prior to version 5.1.1110.4231, used in Lenovo PC Manager, Lenovo Browser, and Lenovo App Store could allow a local attacker with elevated privileges to execute arbitrary code.

Affected products

How to fix

Upgrade to a fixed version: Lenovo App Store 9.0.2230.0617; Lenovo Browser 9.0.6.5061; Lenovo PC Manager 5.1.110.5082. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-4657 or the next vulnerability affects your stack