What’s Vulnerable › Vulnerabilities
CVE-2025-46597
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-190
Description
Bitcoin Core 0.13.0 through 29.x has an integer overflow.
Affected products
- Bitcoin Core: from 0.13.0 before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: Bitcoin Core 0.30.0. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2025/10/24/disclose-cve-2025-46597/
- https://github.com/bitcoin/bitcoin/releases
Get alerted when CVE-2025-46597 or the next vulnerability affects your stack