What’s Vulnerable › Vulnerabilities
CVE-2025-46646
- Severity: medium (CVSS 4.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-26 · updated 2026-06-17
- Weakness: CWE-24
Description
In Artifex Ghostscript before 10.05.0, decode_utf8 in base/gp_utf8.c mishandles overlong UTF-8 encoding. NOTE: this issue exists because of an incomplete fix for CVE-2024-46954.
Affected products
- Artifex Ghostscript: before 10.05.0 — fixed in 10.05.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 10.05.0. Check the vendor advisory for mitigations.
References
- https://bugs.ghostscript.com/show_bug.cgi?id=708311
- https://cgit.ghostscript.com/cgi-bin/cgit.cgi/ghostpdl.git/commit/?id=f14ea81e6c3d2f51593f23cdf13c4679a18f1a3f
Get alerted when CVE-2025-46646 or the next vulnerability affects your stack