What’s Vulnerable › Vulnerabilities
CVE-2025-46647: Apache APISIX: improper validation of issuer from introspection discovery url in plugin openid-connect
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-02 · updated 2026-06-17
- Weakness: CWE-302
Description
A vulnerability of plugin openid-connect in Apache APISIX. This vulnerability will only have an impact if all of the following conditions are met: 1. Use the openid-connect plugin with introspection mode 2. The auth service connected to openid-connect provides services to multiple issuers 3. Multiple issuers share the same private key and relies only on the issuer being different If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer. This issue affects Apache APISIX: until 3.12.0. Users are recommended to upgrade to version 3.12.0 or higher.
Affected products
- Apache Software Foundation Apache APISIX: before 3.12.0 — fixed in 3.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.12.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yrpp2cd3o4qkxlrh421mq8gsrt0k4x0w
- http://www.openwall.com/lists/oss-security/2025/07/02/1
Get alerted when CVE-2025-46647 or the next vulnerability affects your stack