What’s Vulnerable › Vulnerabilities

CVE-2025-46701: Apache Tomcat: Security constraint bypass for CGI scripts

Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.41, 11.0.7, 9.0.105. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-46701 or the next vulnerability affects your stack