What’s Vulnerable › Vulnerabilities
CVE-2025-46724: Langroid has a Code Injection vulnerability in TableChatAgent
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-94
Description
Langroid is a Python framework to build large language model (LLM)-powered applications. Prior to version 0.53.15, `TableChatAgent` uses `pandas eval()`. If fed by untrusted user input, like the case of a public-facing LLM application, it may be vulnerable to code injection. Langroid 0.53.15 sanitizes input to `TableChatAgent` by default to tackle the most common attack vectors, and added several warnings about the risky behavior in the project documentation.
Affected products
- langroid: before 0.53.15 — fixed in 0.53.15
How to fix
Upgrade to a fixed version: langroid 0.53.15. Check the vendor advisory for mitigations.
References
- https://github.com/langroid/langroid/commit/0d9e4a7bb3ae2eef8d38f2e970ff916599a2b2a6
- https://github.com/langroid/langroid/security/advisories/GHSA-jqq5-wc57-f8hj
- https://github.com/langroid/langroid/security/advisories/GHSA-jqq5-wc57-f8hj
Get alerted when CVE-2025-46724 or the next vulnerability affects your stack