What’s Vulnerable › Vulnerabilities
CVE-2025-46725: Langroid has a Code Injection vulnerability in LanceDocChatAgent through vector_store
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-94
Description
Langroid is a Python framework to build large language model (LLM)-powered applications. Prior to version 0.53.15, `LanceDocChatAgent` uses pandas eval() through `compute_from_docs()`. As a result, an attacker may be able to make the agent run malicious commands through `QueryPlan.dataframe_calc]`) compromising the host system. Langroid 0.53.15 sanitizes input to the affected function by default to tackle the most common attack vectors, and added several warnings about the risky behavior in the project documentation.
Affected products
- langroid: before 0.53.15 — fixed in 0.53.15
How to fix
Upgrade to a fixed version: langroid 0.53.15. Check the vendor advisory for mitigations.
References
- https://github.com/langroid/langroid/commit/0d9e4a7bb3ae2eef8d38f2e970ff916599a2b2a6
- https://github.com/langroid/langroid/security/advisories/GHSA-22c2-9gwg-mj59
Get alerted when CVE-2025-46725 or the next vulnerability affects your stack