What’s Vulnerable › Vulnerabilities
CVE-2025-46731: Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-05 · updated 2026-06-17
- Weakness: CWE-1336
Description
Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.
Affected products
- craftcms cms: from 4.1.0 before 4.14.13; from 5.1.0 before 5.6.15; 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 5.0.0-rc1 — fixed in 4.14.13, 5.6.15
How to fix
Upgrade to a fixed version: craftcms cms 4.14.13, 5.6.15. Check the vendor advisory for mitigations.
References
- http://github.com/craftcms/cms/pull/17026
- https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production
- https://github.com/craftcms/cms/security/advisories/GHSA-7c58-g782-9j38
- https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv
Get alerted when CVE-2025-46731 or the next vulnerability affects your stack