What’s Vulnerable › Vulnerabilities
CVE-2025-46762: Apache Parquet Java: Potential malicious code execution from trusted packages in the parquet-avro module when reading an Avro schema from a Parquet file metadata
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-06 · updated 2026-06-17
- Weakness: CWE-73
Description
Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code. While 1.15.1 introduced a fix to restrict untrusted packages, the default setting of trusted packages still allows malicious classes from these packages to be executed. The exploit is only applicable if the client code of parquet-avro uses the "specific" or the "reflect" models deliberately for reading Parquet files. ("generic" model is not impacted) Users are recommended to upgrade to 1.15.2 or set the system property "org.apache.parquet.avro.SERIALIZABLE_PACKAGES" to an empty string on 1.15.1. Both are sufficient to fix the issue.
Affected products
- Apache Software Foundation Apache Parquet Hadoop: before 1.15.2 — fixed in 1.15.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Parquet Hadoop 1.15.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/t7724lpvl110xsbgqwsmrdsns0rhycdp
- http://www.openwall.com/lists/oss-security/2025/05/02/1
Get alerted when CVE-2025-46762 or the next vulnerability affects your stack